Ir para conteúdo
Fórum CódigoFonte.net
  • Anúncios

    • codigofonte

      Novo Fórum

      Pessoal, Atualizamos nossa versão do fórum para a mais recente da Invision Power. Como tínhamos uma versão muito antiga, talvez algumas áreas possam funcionar de forma errada ou com problemas, gostaria de pedir-lhes a compreensão, pois iremos resolvendo aos poucos. Até mais!

buthy

Membros
  • Total de itens

    7
  • Registro em

  • Última visita

  1. Problema ao sobrepor div

    Dae galera... Esse é o site: http://www.buthy.com.br/fisk A intenção é deixar a logomarca em cima da imagem grande... Isso está acontecendo no Chrome, mas no IE e no Firefox a imagem fica para baixo, e não em baixo. Segue algumas screens: Como deve ficar (Chrome): Como fica no IE e no Firefox: CSS: <style type="text/css"> @font-face { font-family: 'delta'; src: url('fonts/delta.eot'); src: url('fonts/delta.eot?#iefix') format('eot'), url('fonts/delta.ttf') format('truetype'); font-weight: normal; font-style: normal; } html, body { height:100%; } body { background-color:#d5d5d5; font-family:"delta"; background:url('images/background.png') no-repeat center top; color:#818181; } *html #base { height:100%; } #base { position:relative; min-height:100%; } #base2 { min-height:100%; padding-bottom:285px; } #linha_cabecalho { width:100%; height:3px; background-color:#cf2026; } #linha_rodape { width:100%; height:3px; background-color:#10437a; } #cabecalho { width:1000px; height:130px; margin:0 auto; } #menu-esq { width:378px; float:left; background-color:#0C0; height:130px; } #logo { width:243px; height:160px; position:relative; z-index:999; float:left; } #menu-dir { width:378px; float:left; background-color:#099; height:130px; } #conteudo-topo { width:1000px; height:5px; margin:0 auto; margin-top:-20px; background:url('images/bg-conteudo-topo.png') no-repeat center; } #conteudo { width:1000px; margin:0 auto; background:url('images/bg-conteudo-meio.png') repeat-y center; min-height:500px; } #conteudo-rodape { width:1240px; height:45px; margin:0 auto; background:url('images/bg-conteudo-rodape.png') no-repeat center; } #slider { width:990px; height:227px; margin:0 auto; z-index:-999; } #slider img, #sobre, #novidades, #cursos { -moz-border-radius: 3px; /* Para Firefox */ -webkit-border-radius: 3px; /*Para Safari e Chrome */ border-radius: 3px; /* Para Opera 10.5+*/ } #sobre { margin:5px 0 0 5px; width:340px; height:300px; background:url('images/bg-sobre-a-fisk.png') no-repeat; overflow:hidden; } #base-rodape{ width:100%; height:290px; position:absolute; bottom:0; } #rodape{ width:1000px; margin:0 auto; padding-top:15px; color:#fff; } #rodape a:visited, #rodape a:link, #rodape a:active, #rodape a:hover { color:#818181; text-decoration:none; font-weight:600; font-size:13px; } #contador { background:url('images/ico-visitantes.png') no-repeat left; padding-left:25px; height:16px; padding-top:8px; } .delta { font-size:12px; font-weight:bold; font-style:normal; color:#818181; } .separador-rodape { width:14px; height:263px; float:left; margin-right:12px; background:url('images/separador-rodape.png') no-repeat center top; } .rodape-item { background:url('images/marcador-rodape.png') no-repeat left; padding-left:10px; margin-bottom:4px; } h1 { font-weight:400; font-size:13px; font-style:normal; color:#cf2026; padding:0 0 7px 0; } h2 { font-weight:400; font-size:13px; font-style:normal; color:#10437a; padding:0 0 7px 0; } </style> Se alguém puder me ajudar a solucionar isso, agradeço! ObrigadoAté mais!
  2. Erro ao fazer upload de imagem

    opa, já resolvi, foi soh um esquecimento do enctype no formulario ahhahaha valeu cara!
  3. Erro ao fazer upload de imagem

    É o seguinte, uso esse código em outro site também, e funciona... Só que agora estou construindo outro site, e não funciona! Já dei chmod 0777 na pasta e tudo, e não funciona! O código é o seguinte: <?php include("verificar.php"); include("../conectar.php"); // inicia criação de pasta if(!empty($nomedapasta)){ @mkdir('../eventos/'.$nomedapasta, 0777); } // fim da criação da pasta if(is_dir('../eventos/'.$nomedapasta) && !empty($foto01)){ $copy = copy($foto01,'../eventos/'.$nomedapasta.'/'.$foto01_name ); if(!$copy){ echo 'Erro ao copiar a foto da capa.'; exit; }else{ mysql_query( 'INSERT INTO `galeria`(`id`,`nome`,`local`,`cidade`,`estado`,`dia`,`mes`,`ano`,`pasta`,`foto01`) VALUES( NULL, "'.$nome.'", "'.$local.'", "'.$cidade.'", "'.$estado.'", "'.$dia.'", "'.$mes.'", "'.$ano.'", "'.$nomedapasta.'", "'.$foto01_name.'")' ) or die( mysql_error() ); } } echo "<script> window.location='eventos_gerenciar.php';</script>"; ?> E o erro: Warning: copy() [function.copy]: Unable to access Associacao001.jpg in /home/deixe/public_html/admin/eventos_cadastrarbd.php on line 12 Warning: copy(Associacao001.jpg) [function.copy]: failed to open stream: No such file or directory in /home/deixe/public_html/admin/eventos_cadastrarbd.php on line 12 Erro ao copiar a foto da capa. A linha 12 é essa: $copy = copy($foto01,'../eventos/'.$nomedapasta.'/'.$foto01_name ); Se alguém puder ajudar eheh Obrigado!
  4. Problema com DIVs no IE8

    coloquei overflow:hidden; em todas as divs e não funcionou não cara :S
  5. Problema com DIVs no IE8

    Então, vou postar screens do que está acontecendo... Essa é a screen de como é no Firefox e no Chrome: http://i54.tinypic.com/t0nq60.jpg E aqui como fica no IE8: http://i54.tinypic.com/k23rt.png O código .CSS: #divMural { width:470px; heigth:165px; float:left; margin-bottom:20px; min-height:165px; background-image:url(../images/bg_box-small.png); background-repeat:no-repeat; } #divFotos { width:470px; height:165px; float:left; min-height:165px; margin-bottom:20px; background-image:url(../images/bg_box-small.png); background-repeat:no-repeat; } #divAgenda { width:470px; height:350px; float:right; margin-left:20px; min-height:350px; margin-bottom:20px; background-image:url(../images/bg_box-big.png); background-repeat:no-repeat; } #divVideos { width:470px; height:350px; float:left; min-height:350px; margin-bottom:20px; background-image:url(../images/bg_box-big.png); background-repeat:no-repeat; } #divTwitter { width:470px; height:350px; float:left; min-height:350px; margin-left:20px; margin-bottom:20px; background-image:url(../images/bg_box-big.png); background-repeat:no-repeat; } #divNovidades { width:470px; height:auto; min-height:350px; float:left; background-image:url(../images/bg_box-big.png); background-repeat:no-repeat; } #divPatrocinadores { width:470px; height:350px; float:left; min-height:350px; margin-left:20px; margin-bottom:50px; background-image:url(../images/bg_box-big.png); background-repeat:no-repeat; } Alguém sabe como resolver isso? Obrigado
  6. Então galera, como o site vai ter um player de música, tive que usar ajax.. e sou beeem iniciante... Consegui uma função que está fazendo exatamente o que eu quero: <script type="text/javascript"> function id( el ){ return document.getElementById( el ); } function pega_arq( url ){ var file = url.split('#'); return ( file[1] ) ? file[1] : 'inicial.html'; } function getHTTPObject(){ if(window.XMLHttpRequest){ return new XMLHttpRequest(); }else if(window.ActiveXObject){ var prefixes = ["MSXML2", "Microsoft", "MSXML", "MSXML3"]; for(var i = 0; i < prefixes.length; i++){ try { return new ActiveXObject(prefixes[i] + ".XMLHTTP"); } catch (e) {} } } } var xmlHttp = getHTTPObject(); function abre( arq ){ xmlHttp.open("GET", arq,true); xmlHttp.onreadystatechange = function(){ if (xmlHttp.readyState == 4){ id('page').innerHTML = xmlHttp.responseText; } } xmlHttp.send( null ); } window.onload = function(){ var as = document.getElementsByTagName('a'); for( var i=0; i<as.length; i++ ){ as[i].onclick = function(){ abre( pega_arq( this.href ) ); } } abre( pega_arq( document.location.href ) ); } </script> só que o problema é o seguinte... no menu topo, quando clica no link, por exemplo: <a href="#biografia.html">BIOGRAFIA</a> ele abre normal.. mas quando tem algum link dentro da página biografia.html, dentro da div page... como que eu faço pra abrir esse link? tem que criar outra função?? muito obrigado!
  7. Problema com paginação de galeria de fotos

    Então galera, é o seguinte, como vocês podem ver nesse link (http://www.fiskfronteira.com.br/eventos...), está tudo normal.. Agora, cliquem para ir para a segunda página. Aparece o seguinte erro: Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/fiskfron/public_html/eventos_fotos.php on line 170 E os dados do banco de dados não são puxados... Só as imagens e o total de fotos. O mesmo acontece quando você volta da segunda página para a primeira... Já pesquisei sobre esse erro, e vi que é algo relacionado com algum erro de digitação, algo que não bate com o que está no BD.. mas não encontrei nenhum erro... O código é o seguinte: include("conexao.php"); $id = $_GET['id']; $consulta= "SELECT * FROM galeria WHERE id = $id"; $res= mysql_query($consulta,$con); while ($linha=mysql_fetch_array($res)){ $nome=$linha['nome']; $descricao=$linha['descricao']; $dia=$linha['dia']; $mes=$linha['mes']; $ano=$linha['ano']; $local = $linha['local']; $unidade = $linha['unidade']; } if (strstr($pg,".")== TRUE){ $pg=ceil($pg); $pg=$pg-1; } if (!$pg==0) { $cont=$pg * 12; } else { $cont=0; } $handle = opendir($dir); $ext = "jpg"; $indice = 0; $ipp = 20; /*define qts fotos por pagina*/ while (false !== ($file = readdir($handle))) { $pathdata = pathinfo($file); if (!is_dir($file) && ($pathdata["extension"] == strtolower($ext)) || ($pathdata["extension"] == strtoupper($ext))) { $imagens[$indice] = $file; $indice++; } } $pagina = 1; if ($_GET['pg']) $pagina = $_GET['pg']; $paginas = ceil(count($imagens) / $ipp); $inicio = $pg * $ipp; $thumb="eventos_imgdim.php?imagem="; $var1 = "&evento=$nome&data=$data&local=$local&unidade=$unidade"; ?> <div class="divScroll"> <br /> <h3><? echo "<img src='img/titulotopo/eventosfisk.png' />"; ?></h3> <br /> <? //$dados= mysql_fetch_array($sql); echo "<div id='Tabela'>"; echo "<div id='divEvento'>"; //if($dados[foto01] != ""){} echo "<div id='divTitulo' style='margin-top:3px;'><span class='data'>$dia/$mes/$ano</span><span class='tit'>$nome</span></div>"; echo "<div id='divDescricao'><span class='subtit'><div id='AlturaDesc'>$descricao</div><br />Local: $local<br /> Unidade de $unidade<br /><br />Total de fotos: "; $total = ceil(count($imagens)); echo $total; ?> <br /><br /><br /> <table align="center" width="500" id="TabelaFotos"> <tr> <td align="center"> <? for ($i=$inicio; $i<($inicio+$ipp); $i++) if($imagens[$i] != ""){ ?> <? $cont=$cont+1; ?> <a rel="example2" href="eventos_img.php?imagem=<? echo "$dir";?><? echo "$imagens[$i]";?>"> <img class="borda" src="<? echo "$thumb$dir$imagens[$i]"; ?>" vspace="4" hspace="4"> </a> <? }?> </td></tr> </td> </tr> </table> <div id="TabelaPag"> <? echo "<div class='divPag'>"; for($i=0; $i<$paginas; $i++){ $url = "?dir=$dir&pg=$i"; if ($i==$pg) { echo "<a href='$url' style='background:#d40119;'><strong>".($i+1)."</strong></a>"; } else { echo "<a href='$url'>".($i+1)."</a>"; } } echo "</div>"; o erro aponta para esta linha: while ($linha=mysql_fetch_array($res)){ tentando explicar o código (que foi modificado do script Galeria Brasil): ele não grava no BD o nome de todas as fotos, ele só grava a pasta onde todas as imagens de certo evento estão... então a idéia seria exibir todas as imagens dentro dessa pasta.. dai separar por páginas, com limite de 20 itens por página... ele até está exibindo as imagens corretamente em suas páginas.. mas daí ocorre esse erro quando troca de página, em que os dados do evento não são mais exibidos... alguém sabe como resolver? obrigado! Editado: RESOLVIDO, pode excluir!
×