Ir para conteúdo
Fórum CódigoFonte.net

rudneyboris

Membros
  • Total de itens

    2
  • Registro em

  • Última visita

Sobre rudneyboris

Últimos Visitantes

O bloco dos últimos visitantes está desativado e não está sendo visualizado por outros usuários.

  1. Tenho que fazer um programa no visualg que peça ao usuário fornecer o número de linhas e colunas de uma matriz, mas não sei fazer isto. Alguém pode me explicar pelo menos como funcionaria a variável, não precisa fazer pra mim. Não tenho ideia mesmo como fazer... Estou tentando colocar um x e y dentro da matriz, mas não dá certo, acho que deva ser de outra maneira. Vou mostrar o que fiz, mas não funciona e tem mais coisas para fazer: var matriz: vetor [x..y] de inteiro a, b: inteiro inicio // Seção de Comandos escreval ("Digite o número de linhas da matriz") leia (x) escreval ("Digite o número de colunas da matriz") leia (y) para a de x ate y faca para b de x ate y faca leia (matriz [a, b]) fimpara fimpara
  2. Olá, Preciso de um programa com duas matrizes de inteiros de números aleatórios, que depois devem ser somados e o resultado impresso em uma terceira matriz. Vou colocar o que consegui embaixo, ele roda, mas não funciona direito. Ajuda por favor. var matriz1: vetor [0..4, 0..4] de inteiro matriz2: vetor [0..4, 0..4] de inteiro matriz3: vetor [0..4, 0..4] de inteiro x, y, a, b, c, d, aux: inteiro inicio // Seção de Comandos aleatorio 10, 20 para x de 0 ate 4 faca para y de 0 ate 4 faca leia (matriz1 [x,y]) para a de 0 ate 4 faca para b de 0 ate 4 faca leia (matriz2 [a,b]) fimpara fimpara fimpara fimpara aleatorio off para x de 0 ate 4 faca para y de 0 ate 4 faca para a de 0 ate 4 faca para b de 0 ate 4 faca aux <- (aux) + (matriz1 [x,y]) + (matriz2 [a,b]) fimpara fimpara fimpara fimpara para x de 0 ate 4 faca para y de 0 ate 4 faca para a de 0 ate 4 faca para b de 0 ate 4 faca para c de 0 ate 4 faca para d de 0 ate 4 faca matriz3 [c,d] <- aux escreval (matriz3 [c,d]) fimpara fimpara fimpara fimpara fimpara fimpara fimalgoritmo
×
×
  • Criar Novo...