Ir para conteúdo
Fórum CódigoFonte.net

Otata

Membros
  • Total de itens

    3
  • Registro em

  • Última visita

Sobre Otata

  • Data de Nascimento 06/03/1987

Contact Methods

  • Website URL
    http://
  • ICQ
    0
  1. Otata

    Erro execute

    eae pessoal estou com um problema chato..bom estou prgramando asp orientado a objetos....e estou com com um problema na classe de conexão na hora de chamala..mais precisamente o execute classe de conexão 'classe para conexão com o banco de dados... Class Conexao Private objConn Public Property Get getConn() 'Propriedade que retorna o objeto de conexão.. getConn = objConn End Property Public function Conn() 'Função que abre a conexão com o bando on error resume next 'Tratando um possível erro.. Set objConn = Server.CreateObject("ADODB.Connection") objConn.Open "Provider=SQLOLEDB.1;Password=12345;Persist Security Info=True;User ID=usrteste;Initial Catalog=dbElektro;Data Source=SSISP02A;" objConn.BeginTrans if err <> 0 then Conn = err.Description 'Retornado o erro. end if Conn = objConn end function Public sub Execute(query) objConn.Execute(query) end sub Public sub fechaConexao() 'Função para Fechar a conexão objConn.Close end sub end Class eu chamo ele assim set conn = new Conexao conn.Conn() 'até ai blz ' problema conn.execute(query) quando eu chamo a função ele da timeOut na página Tipo de erro: Microsoft OLE DB Provider for SQL Server (0x80040E31) Tempo excedido blz espero que possam me ajudar valeu!! :D
  2. Otata

    Classes

    Resolvido pessoal faltava declarar a variavel de conexão valeuu!! <% Class links Private objCon 'Tava faltando rs... Public sub links Set objCon = Server.CreateObject("ADODB.Connection") objCon.Open "Data Source = C :\Inetpub\wwwroot\bd1.mdb;Provider=Microsoft.Jet.OLEDB.4.0;" end sub end Class %>
  3. Otata

    Classes

    Eae pessoal estou iniciando em ASP....e quero trabalhar com classes mas não estou conseguindo fazer uma classe q se conecta ao banco.... links.asp <% Class links Public sub links Set objCon = Server.CreateObject("ADODB.Connection") objCon.Open "Data Source = C :\Inetpub\wwwroot\bd1.mdb;Provider=Microsoft.Jet.OLEDB.4.0;" end sub end Class %> busca.asp <!--#include file = "link.asp"--> <% nome = request.form("txtNome") DIM obj set obj = new links strQ = "SELECT strNome from tbCliente where strNome = '" & nome & "'" Set objRS = obj.links.execute(strQ) if( objRS.EOF ) then response.write("Cliente não encontrado!!") else while Not objRS.EOF Response.Write objRS("strNome") & "<br>" objRS.MoveNext wend end if 'for x = 0 to (UBound(arr)) 'response.write(arr(x)) & "<br>" 'next %> ta ai acho q esta bem errado :D mas por favor me ajudem......valeu!!!
×
×
  • Criar Novo...