Ir para conteúdo
Fórum CódigoFonte.net
Preta_RS

rodar vários swf em um html

Recommended Posts

:rolleyes: Por favor eu criei uma galeria de fotos no flash onde cada foto está em um swf diferente são 8 no total, depois criei um swf chamado principal q é onde as fotos vão carregar em tamanho grande usando alpha, usei action para executar isso e logo após criei um swf chamado galeria q é onde vai executar todos atraves de comandos action...até aí blz td funcionando, criei um link na home do meu projeto pra galeria de fotos o problema começa qdo abro essa página q está em html não roda, no dreamweaver coloquei o swf galeria em uma div, ele abre a galeria.swf mas não roda, fica estático.

Por favor será q alguém poderia me ajudar a solucionar isso é para um trabalho da faculdade q tenho q entregar dia 27....to apavorada de não conseguir resolver isso.

Obrigada! ;)

Compartilhar este post


Link para o post
Compartilhar em outros sites
:rolleyes: Por favor eu criei uma galeria de fotos no flash onde cada foto está em um swf diferente são 8 no total, depois criei um swf chamado principal q é onde as fotos vão carregar em tamanho grande usando alpha, usei action para executar isso e logo após criei um swf chamado galeria q é onde vai executar todos atraves de comandos action...até aí blz td funcionando, criei um link na home do meu projeto pra galeria de fotos o problema começa qdo abro essa página q está em html não roda, no dreamweaver coloquei o swf galeria em uma div, ele abre a galeria.swf mas não roda, fica estático.

Por favor será q alguém poderia me ajudar a solucionar isso é para um trabalho da faculdade q tenho q entregar dia 27....to apavorada de não conseguir resolver isso.

Obrigada! ;)

Olha tá meio confuso.. Tem como vc postar o código?

Compartilhar este post


Link para o post
Compartilhar em outros sites

no swf galeria o código é esse:

loadMovie("principal.swf","alvo");

em cada swf das fotos o código é:

stop();

em cada swf das fotos q são 8 o código é:

on (rollOver)

{

loadMovie("foto1.swf","alvo");

}

lê-se então loadMovie("foto2.swf","alvo"); e assim sucesivamente até o 8

espero q vc consiga me ajudar, não sei se estou sendo clara.

Obrigada pela ajuda!!!

Compartilhar este post


Link para o post
Compartilhar em outros sites
na realidade eu só quero q esse swf abra em um html e rode.

ele tá funcionando perfeitamente menos qdo é inserido no código html

O código a princípio está certo. Veja se no html vc está chamando assim:

<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0" width='xxx' height='xxx' align="xxx">
		   <param name="allowScriptAccess" value="sameDomain" /> 
		   <param name="movie" value="nomedoseufilme.swf" /> 
		   <param name="quality" value="high" />
		   <param name="bgcolor" value="#ffffff" />
			<embed src="nomedoseufilme.swf" quality="high" bgcolor="#ffffff" width='xxx' height='xxx' name="nome" align="xxx" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
			</object>

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora

×
×
  • Criar Novo...