Ir para conteúdo
Fórum CódigoFonte.net
Entre para seguir isso  
lemandrake

Como retiro esses erros: Notice: Use of undefined constant...

Recommended Posts

Boa noite a todos, sou iniciante em PHP, desenvolvi fazendo pesquisas e estudando, um sistema de gerenciamento com login, ao listar os usuários aparece a seguinte mensagem no servidor localhost:

Notice: Use of undefined constant ID - assumed 'ID' in C:\wamp\www\Administrar\restrito2\listar.php on line 218

Ao listar para exclusão:

Notice: Undefined index: acao in C:\wamp\www\Administrar\restrito2\del2.php on line 92

em outro projeto aparece esse erro:

Notice: Undefined variable: acao in C:\wamp\www\teste\Unidades\preexec.php on line 40

No atendimento online:

Notice Undefined offset: in 1 C\www\atendimento\get.php on line 14

Antes de formatar meu micro utilizava o mesmo wampserver com os mesmos arquivos e com a mesma configurações e não apresentava esses erros, no servidor: http://members.000webhost.com/

também não apresenta os erros, gostaria de saber qual o motivo de estar aparecendo esses erros e se tem como anulá-los configurando o wampserver, o motivo pelo qual necessitaria de corrigi-lo em localhost é que dentro desse sistema de login tenho uma agenda que clientes querem alocar em seus micros para cadastro, e dando esses erros não posso vendê-la, agradeço a atenção...se estiverem lendo meu tópico agradeço e se acharem a solução agradeço duas vezes, valeu mesmo, faça sua boa ação do dia, ajude um infanto em PHP...

Compartilhar este post


Link para o post
Compartilhar em outros sites

Talvez seja conflito de versões do PHP, talvez você pode ter testado em versão antiga do PHP e migrou pra uma nova, o pode acarretar em alguns erro (isto é apenas uma suposição)

Notice: Use of undefined constant ID - assumed 'ID'

Provavelmente você está tentando usar uma constante que o sistema não está encontrando

Notice: Undefined index: acao in C:\wamp\www\Administrar\restrito2\del2.php on line 92

Você não definiu essa variável

Notice Undefined offset: in 1 C\www\atendimento\get.php on line 14

Acredito eu que você esteja tentando ler um índice de uma array, porém esse índice é inexistente

Compartilhar este post


Link para o post
Compartilhar em outros sites

procure dentro da pasta do wamp um arquivo chamado php.ini, caso não esteja lá, deve estrar dentro da pasta do windows.

abra com um editor de textos (bloco de notas) e procure pelo seguinte item:

error_reporting = E_ALL

altere para

error_reporting = E_ALL & ~E_NOTICE & ~E_WARNING

salve e reinicie o wamp.

Dúvidas, pode ver o artigo completo aqui: http://justmyself.wordpress.com/2008/01/03/62/

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora
Entre para seguir isso  

×
×
  • Criar Novo...