Ir para conteúdo
Fórum CódigoFonte.net
Entre para seguir isso  
fxguedes

Calculo de pontos - bolao

Recommended Posts

Amigos,

Tenho no site http://www.futebolse...o/bolao2012.asp este bolão para o campeonato paraibano 2012.

Tudo ok, esta funcionando o cadastro dos palpites que estao sendo gravados num banco do access.

Através da opcao participantes, estão sendo mostrados os palpites que estao cadastrados.

Bem, gostaria da ajude de voces para o seguinte:

Como fazer os calculos dos pontos de cada participante ? Sei fazer no excel, só que nao sei fazer em ASP ou Access.

A parte de cadastro de palpites será cancelada assim que começar o campeonato (Não serão mais permitido cadastrar palpites).

Vou cadastrar os resultados na medida que os jogos vão acontecendo.

Como fazer as seguintes contas no arquivo ASP ou no banco do access:

Supondo que: Jogo 1 = Auto Esporte (Mandante) x Esporte (Visitante)

J01M = palpite do mandante do jogo

J01V = palpite do visitante do jogo

R01M = resultado do mandante do jogo

R01V = resultado do visitante do jogo

No excel tenho:

VA1 = SE(J01M=J01V;"Empate";SE(J01M>J01V;"Mandante";"Visitante")) - faz a verificacao p/PALPITES

VO1 = SE(R01M=R01V;"Empate";SE(R01M>R01V;"Mandente";"Visitante")) - faz a verificacao p/RESULTADOS

PV1 = SE(VA1=VO1;2;0) - Atribui dois pontos de forem iguais.

PGE1 = SE(J01M=R01M;1;0) - Atribui um ponto de forem iguais.

PGD1 = SE(J01V=R01V;1;0) - Atribui um ponto de forem iguais.

B1 = SE(PV1+PGE1+PGD1=4;1;0) - Atribui um ponto de bonificacao pelo placar correto.

T1 = (PV1+PGE1+PGD1+B1)

Exemplo:

Palpite = Auto Esporte 1 x 2 Esporte => J01M = 1 e J01V = 2

Resultado = Auto Esporte 1 x 2 Esporte => R01M = 1 e R01V = 2

VA1 = Visitante

VO1 = Visitante

PV1 = 2

PGE1 = 1

PGD1 = 1

B1 = 1

T1 = 5

Resultado = Auto Esporte 1 x 1 Esporte => R01M = 1 e R01V = 1

VA1 = Visitante

VO1 = Empate

PV1 = 0

PGE1 = 1

PGD1 = 0

B1 = 0

T1 = 1

E assim por diante e para todos os palpites.

Alguém poderia me ajudar ??

Agradeço,

fxguedes.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Pessoal,

Consegui fazer os calculos da seguinte maneira:

<%

' Compara o palpite do jogo, pra saber se o placar é empate, vitoria do mandante ou vitoria do visitante.

If (objRS.Fields.Item("J01M").Value) = (objRS.Fields.Item("J01V").Value) Then

VA1 = "Empate"

ElseIf (objRS.Fields.Item("J01M").Value) > (objRS.Fields.Item("J01V").Value) Then

VA1 = "Mandante"

Else

VA1 = "Visitante"

End If

' Compara o palpite do mandante com o resultado, pra saber se são iguais, se sem o participante marca 1 ponto, se nao, 0.

If ((objRS.Fields.Item("J01M").Value)*1) = P01M Then

PGM1 = 1

Else

PGM1 = 0

End If

' Compara o palpite do visitante com o resultado, pra saber se são iguais, se sem o participante marca 1 ponto, se nao, 0.

If ((objRS.Fields.Item("J01V").Value)*1) = P01V Then

PGV1 = 1

Else

PGV1 = 0

End If

' Compara o resultado do jogo, pra saber se o placar é empate, vitoria do mandante ou vitoria do visitante.

If P01M = P01V Then

VO1 = "Empate"

ElseIf P01M > P01V Then

VO1 = "Mandante"

Else

VO1 = "Visitante"

End If

' Compara se o participante acertou o resultado (empate, mandante ou visitante), se sim, marca 2 pontos, se nao 0.

If P01M = "" Then

PV1 = 0

ElseIf VA1 = VO1 Then

PV1 = 2

Else

PV1 = 0

End If

' Verifica se ele acertou o placar correto do jogo, se sim, bonificação de 1 ponto, se nao, 0.

If PGM1 + PGV1 + PV1 = 4 Then

B1 = 1

Else

B1 = 0

End If

'Soma a pontuacao total do participante.

T01 = PGM1 + PGV1 + PV1 + B1

%>

Esta funcionando beleza, só que são 45 jogos e terei que colocar estas rotinas 45 vezes no arquivo, alguém poderia me ajudar a fazer uma rotina que pegasse todos estes valores ?

Tipo um For .....

Aguardo.

Fabio Guedes

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora
Entre para seguir isso  

×
×
  • Criar Novo...