Ir para conteúdo
Fórum CódigoFonte.net
  • Anúncios

    • codigofonte

      Novo Fórum

      Pessoal, Atualizamos nossa versão do fórum para a mais recente da Invision Power. Como tínhamos uma versão muito antiga, talvez algumas áreas possam funcionar de forma errada ou com problemas, gostaria de pedir-lhes a compreensão, pois iremos resolvendo aos poucos. Até mais!
rudneyboris

Dúvida programação visualg

Recommended Posts

Olá,

Preciso de um programa com duas matrizes de inteiros de números aleatórios, que depois devem ser somados e o resultado impresso em uma terceira matriz. Vou colocar o que consegui embaixo, ele roda, mas não funciona direito. Ajuda por favor.

var

matriz1: vetor [0..4, 0..4] de inteiro

matriz2: vetor [0..4, 0..4] de inteiro

matriz3: vetor [0..4, 0..4] de inteiro

x, y, a, b, c, d, aux: inteiro

inicio

// Seção de Comandos

aleatorio 10, 20

para x de 0 ate 4 faca

para y de 0 ate 4 faca

leia (matriz1 [x,y])

para a de 0 ate 4 faca

para b de 0 ate 4 faca

leia (matriz2 [a,b])

fimpara

fimpara

fimpara

fimpara

aleatorio off

para x de 0 ate 4 faca

para y de 0 ate 4 faca

para a de 0 ate 4 faca

para b de 0 ate 4 faca

aux <- (aux) + (matriz1 [x,y]) + (matriz2 [a,b])

fimpara

fimpara

fimpara

fimpara

para x de 0 ate 4 faca

para y de 0 ate 4 faca

para a de 0 ate 4 faca

para b de 0 ate 4 faca

para c de 0 ate 4 faca

para d de 0 ate 4 faca

matriz3 [c,d] <- aux

escreval (matriz3 [c,d])

fimpara

fimpara

fimpara

fimpara

fimpara

fimpara

fimalgoritmo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora

×