Ir para conteúdo
Fórum CódigoFonte.net
rudneyboris

Dúvida programação visualg

Recommended Posts

Olá,

Preciso de um programa com duas matrizes de inteiros de números aleatórios, que depois devem ser somados e o resultado impresso em uma terceira matriz. Vou colocar o que consegui embaixo, ele roda, mas não funciona direito. Ajuda por favor.

var

matriz1: vetor [0..4, 0..4] de inteiro

matriz2: vetor [0..4, 0..4] de inteiro

matriz3: vetor [0..4, 0..4] de inteiro

x, y, a, b, c, d, aux: inteiro

inicio

// Seção de Comandos

aleatorio 10, 20

para x de 0 ate 4 faca

para y de 0 ate 4 faca

leia (matriz1 [x,y])

para a de 0 ate 4 faca

para b de 0 ate 4 faca

leia (matriz2 [a,b])

fimpara

fimpara

fimpara

fimpara

aleatorio off

para x de 0 ate 4 faca

para y de 0 ate 4 faca

para a de 0 ate 4 faca

para b de 0 ate 4 faca

aux <- (aux) + (matriz1 [x,y]) + (matriz2 [a,b])

fimpara

fimpara

fimpara

fimpara

para x de 0 ate 4 faca

para y de 0 ate 4 faca

para a de 0 ate 4 faca

para b de 0 ate 4 faca

para c de 0 ate 4 faca

para d de 0 ate 4 faca

matriz3 [c,d] <- aux

escreval (matriz3 [c,d])

fimpara

fimpara

fimpara

fimpara

fimpara

fimpara

fimalgoritmo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Está precisando de alguma ajuda em programação, desenvolvimento em C, C#, C++, CSS, HTML, JavaScript, PHP, AJAX, Jquery, Laravel, codeigniter, Python, Portugol,
NodeJS, MongoDB, Mysql, Postegre entre outras duvidas entre em contato.

Desenvolvimento de sites, projetos, softwares, blogs, ajudas nas áreas acadêmicas de trabalhos e projetos até provas entre em contato a nossa equipe irá te ajudar.

Email: [email protected] 
Blog: http://marcosprogramacao.blogspot.com.br

Compartilhar este post


Link para o post
Compartilhar em outros sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Visitante
Responder

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Processando...

×
×
  • Criar Novo...