Ir para conteúdo
Fórum CódigoFonte.net
  • Anúncios

    • codigofonte

      Novo Fórum

      Pessoal, Atualizamos nossa versão do fórum para a mais recente da Invision Power. Como tínhamos uma versão muito antiga, talvez algumas áreas possam funcionar de forma errada ou com problemas, gostaria de pedir-lhes a compreensão, pois iremos resolvendo aos poucos. Até mais!
rudneyboris

Matriz visualg dúvida

Recommended Posts

Tenho que fazer um programa no visualg que peça ao usuário fornecer o número de linhas e colunas de uma matriz, mas não sei fazer isto. Alguém pode me explicar pelo menos como funcionaria a variável, não precisa fazer pra mim. Não tenho ideia mesmo como fazer... Estou tentando colocar um x e y dentro da matriz, mas não dá certo, acho que deva ser de outra maneira. Vou mostrar o que fiz, mas não funciona e tem mais coisas para fazer:

var

matriz: vetor [x..y] de inteiro

a, b: inteiro

inicio

// Seção de Comandos

escreval ("Digite o número de linhas da matriz")

leia (x)

escreval ("Digite o número de colunas da matriz")

leia (y)

para a de x ate y faca

para b de x ate y faca

leia (matriz [a, b])

fimpara

fimpara

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora

×