Ir para conteúdo
Fórum CódigoFonte.net
  • Anúncios

    • codigofonte

      Novo Fórum

      Pessoal, Atualizamos nossa versão do fórum para a mais recente da Invision Power. Como tínhamos uma versão muito antiga, talvez algumas áreas possam funcionar de forma errada ou com problemas, gostaria de pedir-lhes a compreensão, pois iremos resolvendo aos poucos. Até mais!
Legendaryz0FCF

Redirecionar para pasta "Internet_Explorer_Edge" !

Recommended Posts

Olá pessoal, tudo blz ??

Sou iniciante em PHP e estou tendo um pequeno probleminha !

Tenho um site no qual eu uso um arquivo redirecionador.php que detecta o 'navegador' por 'HTTP_USER_AGENT' e redireciona para uma pasta do navegador 'específico'. Por exemplo, se o 'HTTP_USER_AGENT' achar a palavra por 'strpos' "MSIE 8.0", redireciona para a pasta 'Internet_Explorer_8', se achar a palavra "Firefox", redireciona para a pasta 'Mozilla_Firefox' !

Estou tentando agora fazer o arquivo encontrar a palavra "Edge/" para fazer redirecioná-lo para a pasta "Internet Explorer Edge" ! eis o código do script abaixo:
 

-------------------
<?php
 
$useragent = $_SERVER['HTTP_USER_AGENT'];

  $FILE_NAME = "index.php";

if(strpos($useragent,"MSIE 8.0")) {
   header("location:Internet_Explorer_8_9/$FILE_NAME");
}

if(strpos($useragent,"MSIE 9.0")) {
   header("location:Internet_Explorer_8_9/$FILE_NAME");
}

if(strpos($useragent,"MSIE 10")) {
   header("location:Internet_Explorer_10/$FILE_NAME");
}

if(strpos($useragent,"rv:11")) {
   header("location:Internet_Explorer_11/$FILE_NAME");
}

if(strpos($useragent,"Edge/", -20)) {
   header("location:Internet_Explorer_Edge/$FILE_NAME");
}

if(strpos($useragent,"Firefox")) {
   header("location:Mozilla_Firefox/$FILE_NAME");
}

if(strpos($useragent,"Chrome")) {
   header("location:Google_Chrome/$FILE_NAME");
}

?>
-------------------

 

O 'HTTP_USER_AGENT' do navegador "Internet_Explorer_Edge" é:

Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.79 Safari/537.36 Edge/14.14393

Como tem a palavra "Mozilla" e "Chrome" partindo do início, eu utilizei o 'offset' do 'strpos' para '-20', que começa a procurar a palavra contando 20 caracteres para trás partindo do final. Só que ele recireciona para a pasta "Google Chrome" ! Preciso fazer redirecionar para a pasta "Internet Explorer Edge" e não sei o que está errado !

Será que alguém poderia me dar uma ajuda ? É meio que urgente por favor !
No aguardo
Carlos

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora

×