Ir para conteúdo
Fórum CódigoFonte.net
Entre para seguir isso  
lucas almeida

Ajuda com email em ASP

Recommended Posts

Pessoal

Preciso de uma ajuda de voces...

Fiz uma página em ASP que envia o email, aí quando faço o teste na pag e envio o email, ele chega assim...

2 Salientamos que já foram executados os procedimentos padrões de verificação neste AR (monitoração do SITAG, link e ativos).

CGC - Nome da unidade Horario de inicio do problema

7435-PV BARREIRO/12:06:00

7174-GIFUGBH/21:12:12

0081-PV TUPINAMBAS/54:45:54

eu queria que ele chegasse sempre assim:

CGC - Nome da unidade Horario de inicio do problema

7435-PV BARREIRO 12:06:00

7174-GIFUGBH 21:12:12

0081-PV TUPINAMBAS 54:45:54

não quero que os dados cheguem de forma desordenada....só isso..

vou postar meu codigo que envia o email para ver se vcs podem me ajudar..

'---------------------------------ENVIO DE EMAIL--------------------------------------
  '"À<br> GISUTBH02<br>C/c GIFUG/BH<br><br> 1&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Favor realizar as alterações abaixo:<br><br>1.1&nbsp;&nbsp;&nbsp;    Favor incluir no Servidor :"&servidor&", Grupo: "&grupo&" o (os) usuário (os): "&matricula&".<br><br>Atenciosamente,<br> "&strNome&"  - "&strMatricula&"<br>GIFUG/BH"
  Set objMail = Server.CreateObject("CDONTS.NewMail")
  objMail.From= ""&strMatricula&"@mail.dominio"
  'objMail.To= ""&strMatricula&"@mail.dominio"
  objMail.To= "[email protected];"&strMatricula&"@mail.dominio"
  'objMail.CC=""&strCp_gerencia&"@mail.dominio"
  objMail.Subject="#05 - PV com status NR no SIWAM"
  objMail.BodyFormat=0
  objMail.MailFormat=0
  body= "<html>" _
  
    & "<head>" _
    
    & "</head>" _
    & "<body bgcolor=""white"">" _
    & "<font face=""Arial"" size=""2"">" _
    & "<font face=""Arial"" size=""2"" color=""black"">Ao </font><br> "_
    & "<font face=""Arial"" size=""2"" color=""black"">Suporte</font><br>"_
    & "<font face=""Arial"" size=""2"" color=""black"">c/c Relacionamento</font><br><br> "_
    & "<font face=""Arial"" size=""2"" color=""black"">1&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;    Informamos que  os PV relacionados abaixo estão com status NR (não responde) no sistema SIWAM (http://www.siwam.coresp.dominio/):<br><br>"_
    & "<font face=""Arial"" size=""2"" color=""black"">2&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;    Salientamos que já foram executados os procedimentos padrões de verificação neste AR (monitoração do SITAG, link e ativos).</font><br><br>"
    
    body= body& "<DL><dd><font face=""Arial"" size=""2"" color=""black"">    CGC - Nome da unidade &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Hora inicio do problema</font>" 
    body= body& "<font face=""Arial"" size=""2"" color=""black"">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;    "& Replace(texto, vbcrlf,"<br>")&" </font><br></dl>"

    body= body & "<font face=""Arial"" size=""2"" color=""black"">3&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;    Solicitamos providências desse Suporte com relação aos servidores.</font><br><br>"_

    & "<font face=""Arial"" size=""2"" color=""black"">Atenciosamente</font><br>"_
    & "<font face=""Arial"" size=""2"" color=""black"">"& strNome&" - "& strMatricula&".</font><br> "_
    & "<font face=""Arial"" size=""2"" color=""black"">Ambiente de Rede</font><br> "_
    & "</body>" _
    & "</html>"    

grato

Lucas

Ops

Acabou que o exempo q eu coloquei nao ficaram formatados

mas é para ficar tipo quando tem tabela com borda"0"...

Compartilhar este post


Link para o post
Compartilhar em outros sites

Pessoal

Preciso de uma ajuda de voces...

Fiz uma página em ASP que envia o email, aí quando faço o teste na pag e envio o email, ele chega assim...

2 Salientamos que já foram executados os procedimentos padrões de verificação neste AR (monitoração do SITAG, link e ativos).

CGC - Nome da unidade Horario de inicio do problema

7435-PV BARREIRO/12:06:00

7174-GIFUGBH/21:12:12

0081-PV TUPINAMBAS/54:45:54

eu queria que ele chegasse sempre assim:

CGC - Nome da unidade Horario de inicio do problema

7435-PV BARREIRO 12:06:00

7174-GIFUGBH 21:12:12

0081-PV TUPINAMBAS 54:45:54

não quero que os dados cheguem de forma desordenada....só isso..

vou postar meu codigo que envia o email para ver se vcs podem me ajudar..

'---------------------------------ENVIO DE EMAIL--------------------------------------
  '"À<br> GISUTBH02<br>C/c GIFUG/BH<br><br> 1&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Favor realizar as alterações abaixo:<br><br>1.1&nbsp;&nbsp;&nbsp;    Favor incluir no Servidor :"&servidor&", Grupo: "&grupo&" o (os) usuário (os): "&matricula&".<br><br>Atenciosamente,<br> "&strNome&"  - "&strMatricula&"<br>GIFUG/BH"
  Set objMail = Server.CreateObject("CDONTS.NewMail")
  objMail.From= ""&strMatricula&"@mail.dominio"
  'objMail.To= ""&strMatricula&"@mail.dominio"
  objMail.To= "[email protected];"&strMatricula&"@mail.dominio"
  'objMail.CC=""&strCp_gerencia&"@mail.dominio"
  objMail.Subject="#05 - PV com status NR no SIWAM"
  objMail.BodyFormat=0
  objMail.MailFormat=0
  body= "<html>" _
  
    & "<head>" _
    
    & "</head>" _
    & "<body bgcolor=""white"">" _
    & "<font face=""Arial"" size=""2"">" _
    & "<font face=""Arial"" size=""2"" color=""black"">Ao </font><br> "_
    & "<font face=""Arial"" size=""2"" color=""black"">Suporte</font><br>"_
    & "<font face=""Arial"" size=""2"" color=""black"">c/c Relacionamento</font><br><br> "_
    & "<font face=""Arial"" size=""2"" color=""black"">1&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;    Informamos que  os PV relacionados abaixo estão com status NR (não responde) no sistema SIWAM (http://www.siwam.coresp.dominio/):<br><br>"_
    & "<font face=""Arial"" size=""2"" color=""black"">2&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;    Salientamos que já foram executados os procedimentos padrões de verificação neste AR (monitoração do SITAG, link e ativos).</font><br><br>"
    
    body= body& "<DL><dd><font face=""Arial"" size=""2"" color=""black"">    CGC - Nome da unidade &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Hora inicio do problema</font>" 
    body= body& "<font face=""Arial"" size=""2"" color=""black"">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;    "& Replace(texto, vbcrlf,"<br>")&" </font><br></dl>"

    body= body & "<font face=""Arial"" size=""2"" color=""black"">3&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;    Solicitamos providências desse Suporte com relação aos servidores.</font><br><br>"_

    & "<font face=""Arial"" size=""2"" color=""black"">Atenciosamente</font><br>"_
    & "<font face=""Arial"" size=""2"" color=""black"">"& strNome&" - "& strMatricula&".</font><br> "_
    & "<font face=""Arial"" size=""2"" color=""black"">Ambiente de Rede</font><br> "_
    & "</body>" _
    & "</html>"    

grato

Lucas

Ops

Acabou que o exempo q eu coloquei nao ficaram formatados

mas é para ficar tipo quando tem tabela com borda"0"...

Lucas,

testa assim e ve se funciona.

body= body& "<font face=""Arial"" size=""2"" color=""black"">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;

"&Replace(Replace(texto, vbcrlf,"<br>"),"/"," ") &"</font><br></dl>"

:)

Editado por pdgori

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora
Entre para seguir isso  

×
×
  • Criar Novo...